[해결] 몇 개의 파일을 복사할 수 없기 때문에 업데이트는 설치할 수 없습니다. 이것은 보통 파일의 퍼미션이 서로 다르기 때문입니다.: wp-admin/includes/update-core.php

몇 개의 파일을 복사할 수 없기 때문에 업데이트는 설치할 수 없습니다. 이것은 보통 파일의 퍼미션이 서로 다르기 때문입니다.: wp-admin/includes/update-core.php

권한 문제로 워드프레스 업데이트가 되지 않는경우 입니다.

이 경우는 아주 간단하게 퍼미션 해결하면 바로 끝납니다.

업로드한 파일의 퍼미션(권한)을 설정합니다.

파일을 644모드로 변경합니다.

find . -type f -exec chmod 644 {} \;

폴더를 755모드로 변경합니다.

find . -type d -exec chmod 755 {} \;

755로 안될경우 모두 777로 바꾸셔서 업데이트 하시고 다시 기존대로 돌리면됩니다.

아파치권한으로 모든폴더와 파일을 수정합니다.

chown apache.apache -R /wordpress

자! 이제 업데이트를 다시 눌러볼까요~

업데이트가 잘 진행되는군요^^

축하합니다.

그리고 다시 파일 퍼미션과 디렉토리 퍼미션을 기존대로 돌리시면됩니다.

혹시 이렇게 777 퍼미션으로 바꾸어도 안된다면 SELinux 때문입니다.

이부분은 아래 글을 참조하셔서 해결하면됩니다.

 

SELinux Disabled 설정방법 바로보기